Solution: Error while publishing workflow or workflow cancels on start. (The requested service could not be activated)

Hi,

Today I stumbled into the following error message while was publishing SPD 2013 workflow:

130403_01

Errors were found when compiling the workflow. The workflow files were saved but cannot be run.

Microsoft.Workflow.Client.WorkflowCommunicationException: The request was aborted: The request was canceled. Client ActivityId : 7a290e9c-0917-7088-afc4-e65fd25c5c0b. ---> System.Net.WebException: The request was aborted: The request was canceled. ---> System.ServiceModel.ServiceActivationException: The requested service, 'net.pipe://localhost/SecurityTokenServiceApplication/appsts.svc' could not be activated. See the server's diagnostic trace logs for more information.

Server stack trace:

Another symptom is that workflow cancels on start with the following error message:

130403_02

 

RequestorId: f58f8045-c8ff-3ff0-d7d3-d4b4bb8bb7ba. Details: System.ApplicationException: HTTP 500
The requested service, 'http://ch02sp01:32843/60cb2361c56a44639e185aec7d585ba6/AppMng.svc' could not be activated. See the server's diagnostic trace logs for more information.
{"SPRequestGuid":["f58f8045-c8ff-3ff0-d7d3-d4b4bb8bb7ba"],"request-id":["f58f8045-c8ff-3ff0-d7d3-d4b4bb8bb7ba"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["125"],"SPIisLatency":["0"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Wed, 03 Apr 2013 15:17:02 GMT"],"Server":["Microsoft-IIS\/7.5"],"X-Powered-By":["ASP.NET"]}
   at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context)
   at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

 

The cause of the issues is very simple. There was not enough memory to start the service. So the solution is simple, just free up some memory.

Hope it saves somebody some time. If so, please, press upvote on the bottom of the post 🙂

Regards, Michael.

7 thoughts on “Solution: Error while publishing workflow or workflow cancels on start. (The requested service could not be activated)

  1. Hi,

    Thanks for the tip. Actually my App is having 7 GB Free space and my WFE is having 12 GB. Is it not sufficient ? Please suggest me.


    Rao

Leave a Reply

Your email address will not be published. Required fields are marked *